@genobreaker

use battery saver (the built in).. works for me

and Also check settings/display/ (turn on battery saver brightness)